Oscilloscope

OSCILLOSCOPE VIRTUEL

Généralités

L'oscilloscope VSM est présent, en standard, dans toutes les versions de ProSPICE et modélise une unité analogique à quatre voies comme spécifié ci-dessous:

  • Quatre voies ou opération X-Y.
  • Voies avec gain de 20V/div à 2mV/div avec un zoom 2.5x.
  • Temps de base de 200ms/div à 0.5us/div avec un zoom 2.5x.
  • Déclenchement automatique sur niveau de tension verrouillé sur chaque voie.
  • Entrées couplées AC ou DC.
  • Modes voies A+B et C+D.
  • Bouton d’inversion sur chaque voie.
  • Zoom avant et arrière (avec la souris).
  • Mesures par curseurs.
  • Mode ‘monocoup’ avec possibilité de zoom avant et arrière.
  • Impression.
  • Couleurs différentes permettant de distinguer chaque voie.

Utiliser l'oscilloscope

Pour visualiser les signaux analogiques:

  1. Prenez un objet OSCILLOSCOPE dans le sélecteur d’objet, après avoir validé l’icone Mode instruments virtuels sous ISIS.

  2. Placez l’objet sur votre schéma et connectez ses entrées aux signaux que vous voulez visualiser.

  3. Lancez une simulation interactive en appuyant sur le bouton 'Play' du contrôle d'animation.La fenêtre oscilloscope doit apparaître.

  4. Positionnez le bouton de la base de temps (groupe Horizontal) sur une valeur permettant une visualisation aisée des signaux. Vous devez pour cela connaître approximativement la fréquence des signaux que vous souhaitez visualiser. Pour connaître le durée d’une période il vous suffit d’effectuer l’opération réciproque 1/fréquence.

  5. Si vous souhaitez afficher un signal présentant un offset DC important, vous devriez utiliser le mode AC afin de le centrer autour de 0V (GND). Pour dévalider l’affichage d’une voie, lorsqu’elle n’est pas utilisée, mettez le commutateur sur OFF.

  6. Ajustez les boutons rotatifs de position et de tension de chaque signal sur la Voie A...Voie D de sorte à ce que les signaux soit correctement visualisés.Si vous êtes en présence d’un faible signal AC superposé à une forte tension continue DC, vous devrez peut-être placer un condensateur entre le point de mesure et l’oscilloscope, car le contrôle de position ne peut compenser qu’un certain niveau DC.

  7. Choisissez la voie où sur laquelle est connecté le signal de déclenchement (trigger) à l’aide du commutateur horizontal du groupe Trigger.

  8. Choisissez la portion du signal qui va déclencher l’acquisition. Il est possible de verrouiller le trigger sur une pente croissante ou décroissante selon la position du commutateur vertical.

Modes d'operation

Les modes suivants sont disponibles:

  • Auto - La LED du bouton Auto est allumée dans ce mode.
  • One-Shot - La LED du bouton Auto est éteinte. Dans ce mode la LED du bouton One-Shot s’allume pendant la capture du signal et s’éteint ensuite.
  • Mode X-Y - Vous pouvez positionner le curseur sur la voie X à l'aide du curseur.

Déclenchement

L'oscilloscope VSM fournit un mécanisme de déclenchement automatique qui synchronise la temps de base sur la forme d'onde incidente.

  • Le commutateur Source du groupe Trigger permet de choisir la voie de déclenchement.
  • Le commutateur AC/DC est utilisé pour valider la tension absolue ou la tension d’offset de la voie de déclenchement.
  • Le bouton rotatif Level valide la tension d’offset .
  • Le commutateur Edge valide le trigger sur le front montant ou descendant du signal.

Couplage en entrée

Chaque voie d’entrée peut être couplée directement (couplage DC) ou via un condensateur simulé (couplage AC). Le second mode est pratique pour visualiser les signaux AC faibles superposés à une tension continue DC importante.

Les entrées peuvent également être mises temporairement à la masse (GND) afin d’aligner la trace avant les mesures effectives. Chacune des voies peut être désactivée en validant la position OFF. Deux des voies peuvent être additionnées en utilisant les boutons A+B ou C+D.

Vous pouvez utilisez le bouton Invert pour inverser le signe de la tension de chaque voie.

Mesures

En utilisant les curseurs, vous pourrez mesurer de manière précise une tension, une différence de tension, ou encore une différence de temps (entre le point de déclenchement et deux points quelconques par exemple). Pour utiliser cette fonctionnalité actionnez le bouton 'Curseurs'. Pour placer un curseur absolu à l’écran, il vous suffit de positionner le pointeur de la souris à la position appropriée puis de cliquer gauche. Pour positionner un autre curseur, déplacez la souris en maintenant le bouton gauche enfoncé. Les curseurs peuvent être déplacés avec la souris (lorsque la souris est placée au-dessus d’une ligne) ou supprimés, en utilisant le menu contextuel – commandes “Supprimer curseur” ou “Effacer tous les curseurs”.

Deleting a Cursor from the Oscilloscope

Impression

Toutes les traces affichées à l’écran peuvent être imprimées en utilisant la commande “Print…” du menu contextuel.

Couleurs

Les couleurs de chaque voie peuvent être modifiées via la boîte de dialogue “Colours Setup...” du menu contextuel.

Vous pouvez également modifier les couleurs en cliquant droit sur l'oscilloscope.


Logic Analyser

MODELE D'ANALYSEUR LOGIQUE

Généralités

L’analyseur logique VSM est présent, en standard, dans toutes les versions de ProSPICE.

Un analyseur logique opère en enregistrant de manière continue les données numériques dans un grand tampon de stockage. C'est un processus d'échantillonnage, donc il existe une résolution ajustable qui définit la plus petite impulsion pouvant être mémorisée. Une section de déclenchement contrôle les données entrantes et force l'arrêt du processus de capture après que la condition de déclenchement ait été atteinte; la capture commence en armant l'instrument. En conséquence, le contenu du tampon de capture peut être affiché avant et après le temps de déclenchement. Comme le tampon de capture est très large (40000 échantillons, dans ce cas), ceci autorise un zoom et un panoramique de l'affichage. Enfin, des marqueurs de mesures réalisent des mesures précises telles que des largeurs d'impulsion, et ainsi de suite.

Les caractéristiques de l'analyseur logique VSM 24 canaux sont:

  • 8 courbes 1 bit et 4 bus 8 bits.

  • Tampon de capture 40000 x 52 bits.

  • Résolution de la capture de 200us par échantillon à 0.5ns par échantillon qui correspond à des temps de capture de 4s à 10ns.

  • Zoom d'affichage réglable de 1000 échantillons par division à 1 échantillon par division.

  • Déclenchement sur combinaison ET de l'état des entrées et/ou fronts, et valeurs des bus.

  • Position du déclenchement de –50% à +50% du tampon de capture.

  • Des curseurs sont disponibles pour des mesures temporelles précises.

Utilisation de l'analyseur logique

Pour capturer et visualiser des données numériques:

  1. Prenez un objet LOGIC ANALYSER dans le sélecteur d’objet, après avoir validé l’icone Mode instruments virtuels sous ISIS . Placez-le sur le schéma et connectez ses entrées sur le signal que vous voulez enregistrer.

  2. Lancez la simulation interactive en appuyant sur le bouton 'Play' du panneau de contrôle de l'animation. La fenêtre de l'analyseur logique doit apparaître.

  3. Utilisez le bouton de résolution pour définir une valeur convenable. Celle-ci représente la plus petite largeur d'impulsion pouvant être enregistrée. Plus la résolution est petite, plus petit sera le temps d'enregistrement.

  4. Validez les listes déroulantes à gauche de l'instrument pour définir les conditions de déclenchement. Par exemple, si vous désirez déclencher lorsque le signal sur la voie 1 est à l'état haut, et que celui sur la voie 3 est une transition montante, vous devez valider la première liste avec 'High' et la troisième avec 'Low-High'.

  5. Décidez de la proportion des données à voir avant ou après que la condition de déclenchement soit intervenue, et placez le bouton rotatif Position.

  6. Lorsque vous êtes prêt, cliquez sur le bouton 'Capture' pour armer l'instrument. La LED correspondante s’allumera en rose. L'analyseur logique capture les données incidentes de manière continue tout en testant les conditions de déclenchement des entrées. Lorsque les conditions sont vérifiées, la LED du bouton Capture devient verte. La capture des données se poursuit jusqu'au remplissage de tampon. Dès cet instant, la LED s'éteint et le tampon est visualisé.

Panoramique et zoom

Comme la taille du tampon de capture contient plus échantillons que la largeur de l'afficheur, qui est de 400 pixels, il faut permettre un panoramique et un zoom du tampon de capture. Le bouton rotatif Display Scale détermine le nombre d’échantillons par division, alors que l’ascenseur horizontal de l’afficheur permet de se déplacer vers la gauche ou la droite.

Noter que le texte placé au-dessous du bouton Display Scale affiche le temps courant par division en secondes, et non pas la valeur courant du bouton lui-même. Le temps de division est calculé en multipliant la valeur du zoom par la résolution.

Mesures

En utilisant les curseurs ajustables , vous pourrez mesurer des temps très précisément. Pour utiliser cette fonctionnalité actionnez le bouton Cursors. Pour placer un curseur absolu à l’écran, il vous suffit de positionner le pointeur de la souris à la position appropriée puis de cliquer gauche. Pour positionner un autre curseur, déplacez la souris en maintenant le bouton gauche enfoncé. Les curseurs peuvent être déplacés avec la souris (lorsque la souris est placée au-dessus d’une ligne) ou supprimés, en utilisant le menu contextuel – commandes “Supprimer curseurs” ou “Effacer tous les curseurs”.

Impression

Toutes les traces affichées à l’écran peuvent être imprimées en utilisant la commande “Imprimer…” du menu contextuel.

Couleurs

Les couleurs de chaque voie peuvent être modifiées via la boîte de dialogue “Configfurer couleurs” du menu contextuel..


Signal Generator

MODELE DE GENERATEUR DE SIGNAL

Généralités

Le générateur de signaux audio VSM est présent, en standard, dans toutes les versions de ProSPICE.

Il modélise un générateur audio simple avec les dispositifs suivants :

  • Génération de signaux carrés, en dents de scie, triangulaires et sinus.
  • Fréquence de sortie de 0-12MHz en 8 gammes
  • Amplitude de sortie de 0-12V en 4 gammes.
  • Entrées de modulation en amplitude et fréquence.

Utiliser le générateur de signal

Mise en place d’un simple signal audio:

  1. Prenez un objet SIGNAL GENERATOR dans le sélecteur d’objet , après avoir validé l’icone Mode instruments virtuels sous ISIS . Reliez-le à votre circuit de la même manière qu’un composant. Dans la plupart des cas (sauf si vous souhaitez définir une source équilibrée), vous voudrez mettre la broche –ve du générateur à la terre. Vous pouvez le faire facilement en utilisant un terminal GROUND. Les entrées amplitude et fréquence de modulation peuvent rester “en l’air” si vous n’utilisez pas de modulation

  2. Démarrez une simulation interactive en cliquant sur le bouton Play du Panneau de contrôle de simulation interactive. La fenêtre du générateur de signal devrait apparaître.

  3. Définissez une gamme de fréquence appropriée à votre circuit. La valeur Range indique la fréquence qui est générée lorsque la valeur Centre est égale à 1.

  4. Définissez une gamme d’amplitude appropriée à votre circuit. La valeur Range indique l’amplitude qui est générée lorsque que la valeur Level est égale à 1.

  5. Cliquez sur le bouton Waveform jusqu’à ce que la LED correspondante au signal souhaité soit affichée.

Utilisation d'entrées de modulations AM & FM

Le générateur de signal admet de moduler la sortie en amplitude et en fréquence.

Les entrées d'amplitude et de fréquence possèdent les caractéristiques suivantes:

  • Le gain de l'entrée de modulation en Hz/V ou V/V peut être défini en utilisant respectivement le contrôle Frequency Range et Amplitude Range.
  • L’entrée de modulation est écrêtée à +/- 12V.
  • Les entrées de modulation ont une impédance d’entrée infinie.
  • La tension sur l’entrée de modulation est ajoutée à la valeur du vernier de contrôle approprié avant d’être multipliée par la valeur Range, pour définir la fréquence instantanée de l’amplitude de sortie.

Par exemple, si la fréquence est configurée à 1 KHz avec un facteur de multiplication de 2.0, alors le niveau de modulation de fréquence de 2V engendrera une fréquence de sortie de 4 KHz.


Pattern Generator

MODELE DE GENERATEUR DE PATTERN

Généralités

Le générateur de trame VSM est présent, en standard, dans toutes les versions de ProSPICE.

Il permet de définir jusqu’à 1 kilo-octet de trames de 8 bits et possède les fonctionnalités suivantes :

  • Fonctionne avec la simulation par graphes ainsi que sous la simulation interactive.
  • Horloge interne et externe, et boutons de trigger.
  • Boutons de réglage de l’horloge et du trigger.
  • Affichage hexadécimal ou décimal.
  • Possibilité de saisir directement des valeurs pour une meilleure précision.
  • Chargement et enregistrement de scripts de trames.
  • Configuration manuelle de la période de la trame.
  • Possibilité d’avancer la trame en mode pas à pas.
  • Affichage d’une info bulle permettant de voir exactement où vous êtes sur la grille.
  • Possibilité de verrouiller la trame sur son état courant.
  • Commandes d’édition avancées permettant une saisie plus facile de la trame.

Utiliser le générateur de Pattern

Générer une trame lors d’une simulation interactive:

  1. Prenez le PATTGEN dans le sélecteur d’objets (validez l’icône Mode instruments virtuels). Reliez -le à votre circuit de la même manière qu’un composant.

  2. Lancez une simulation interactive en cliquant sur le bouton pause du Panneau de contrôle de simulation interactive. La fenêtre du générateur de signal devrait apparaître.

  3. Dessinez la trame que vous souhaitez générer. Pour cela, cliquez gauche sur la grille afin de définir les états logiques.

  4. Choisissez l’horloge à utiliser (interne, ou externe) en cliquant sur le bouton Clock .

  5. Si vous utilisez une horloge interne réglez sa fréq uence d'horloge.

  6. Choisissez entre l’utilisation d’un trigger interne ou externe, en cliquant sur le premier bouton du groupe Trigger. Si vous utilisez un trigger externe pensez à indiquer s’il est synchrone ou non avec l’horloge.

  7. Si vous utilisez un trigger interne, utilisez le bouton rotatif Trigger pour indiquer la fréquence de déclenchement.

  8. Appuyez sur le bouton Play du Panneau de contrôle de simulation interactive pour générer la trame.

  9. Pour avancer la trame d’un pas d’horloge, il faut suspendre la simulation depuis le panneau de contrôle, puis appuyez sur le bouton Pas à pas .

See Trigger Modes for details of the different trigger modes available with the Pattern Generator.

See Additional Functionality for more information on configuring and using the Pattern Generator.

Génération d’une trame lors d’une simulation par graphes:

  1. Réalisez votre schéma de la manière habituelle.
  2. Positionnez les sondes aux pointes d'intérêt sur le schéma et ajouter ces sondes aux graphes.
  3. Cliquez droit puis gauche sur le générateur de trame pour le sélectionner afin de l’éditer.

  4. Configurez les options de trigger et d’horloge.

  5. Chargez le fichier de trame désiré via le champ Pattern Generator Script.

  6. Validez le tout et pressez la barre d’espace pour lancer la simulation.

Les broches du composant générateur de pattern

Broche de données de sortie (Sortie Tri-State)

Vous pouvez utiliser les broches individuelles et/ou la sortie bus.

Broche Clockout (Sortie)

Lorsque le générateur est synchronisé en interne, vous pouvez utiliser cette broche qui reproduit l’horloge interne. Par défaut cette broche est désactivée, mais vous pouvez l’activer en éditant le générateur. Attention, pour des horloges à haute fréquence, cette sortie utilise fortement les ressources du processeur.

Broche Cascade (Sortie)

La broche Cascade est mise à l’état haut lorsque le premier bit intervient et le restera jusqu’à l’arrivée du dernier bit (un cycle d’horloge plus tard). Elle sera donc à l’état haut au lancement de la simulation et à nouveau au premier cycle d’horloge qui suit un reset.

Broche Trigger (Entrée)

Cette broche d’entrée est utilisée pour appliquer un trigger externe au générateur. Il existe quatre modes différents.

Broche Clock-In (Entrée)

Cette broche d’entrée est utilisée pour appliquer une horloge externe au générateur. Il existe deux modes différents.

Broche Hold (Entrée)

Cette entrée lorsqu’elle est à l’état haut met en pause le générateur. Le pattern restera en l’état jusqu’à ce que la broche soit relâchée. Pour une clock interne et/ou un trigger, le timing reprend relativement au point où il a été suspendu. Par exemple, avec une horloge interne de 1Hz, si une pause débute à t=3,6s et s’arrête à t=5,2s le prochain front descendant d'horloge aura lieu à t=5,6s.

Broche Output Enable (Entrée)

Cette broche doit être à l’état haut pour activer les sorties. Si la broche n’est pas à l’état haut, bien que la pattern continue de progresser en interne, il ne sera pas répercuté sur les broches de sortie.

Modes d’horloge

Horloge interne

L’horloge interne est négative, c'est-à-dire qu’une impulsion suit le cycle bas-haut -bas. Ce mode d’horloge peut être choisi avant la simulation, via l’édition du générateur de trame ou pendant une pause de la simulation via le bouton de sélection d’horloge de la fenêtre du générateur de trame.

La broche Clockout , lorsqu’elle est activée, est équivalente à l’horloge interne. Par défaut, elle est désactivée - puisqu’elle est gourmande en performance (particulièrement avec de hautes fréquences d’horloge) - mais peut être activée via la boîte d’édition du générateur de trame.

Horloge externe

Il existe deux horloges externes – front descendant (bas-haut-bas) et front montant (haut -bashaut).

Connectez votre horloge externe à l’entrée CLKIN et sélectionnez l’un des deux modes externe.

Le mode peut être choisi avant la simulation, via l’édition du générateur de trame ou pendant une pause de la simulation via le bouton de sélection d’horloge de la fenêtre du générateur de trame.

Modes de déclenchement

Trigger interne

Le mode de trigger interne déclenche les patterns à des intervalles spécifiés. Lorsque l’horloge est interne, l'impulsion d'horloge est remise à zéro à l’instant spécifiée. Le comportement est celui indiqué ci-dessous.

Horloge interne à 1Hz et la broche trigger passe à l’état haut à 3.75sec. La broche Cascade est haute lorsque le premier bit du pattern est dirigé vers les sorties et basse le reste du temps.

Notez qu’au temps de déclenchement, l’horloge interne est réinitialisée de façon asynchrone. Le premier bit du pattern est dirigé sur les pins de sortie (ceci est mis en évidence par le passage à l’état haut de la patte Cascade).

Déclenchement asynchrone externe, sur front montant

Le déclenchement (trigger) est spécifié via une transition positive de la broche Trigger. Le trigger est pris en compte immédiatement et le prochain front d’horloge sera une transition bas -haut au temps bitclock/2 qui suit le reset – comme indiqué ci-dessous.

Horloge interne à 1Hz et la broche trigger passe à l’état haut à 3.75sec. L’horloge est immédiatement réinitialisée sur le front positif de la broche trigger, et le premier bit du pattern est dirigé vers les sorties.

Déclenchement synchrone externe, sur front montant

Le déclenchement (trigger) est spécifié via une transition positive de la broche Trigger. Le trigger est mémorisé et interviendra en synchronisme avec le prochain front descendant de l’horloge – comme indiqué ci-dessous.

Horloge interne à 1Hz. L’horloge n’est pas affectée par le trigger. L’action du trigger débute sur le front descendant de l’horloge qui suit l’impulsion positive.

Déclenchement synchrone externe, sur front descendant

Le déclenchement (trigger) est spécifié via une transition négative de la pin Trigger. Le trigger est mémorisé et les bits du pattern sont dirigés vers la sortie.

Horloge interne à 1Hz. L’horloge est réinitialisée sur le front descendant de l’impulsion de trigger et le premier bit du pattern est validé à cet instant.

Déclenchement synchrone externe, sur front descendant

Le déclenchement (trigger) est spécifié via une transition négative de la pin Trigger. Le trigger est mémorisé et son action est synchrone du prochain front descendant de l’horloge – comme indiqué ci-dessous.

Horloge interne à 1Hz. L’horloge est réinitialisée sur le front descendant de l’impulsion de trigger et le pattern n’est réinitialisé qu’au front descendant de l’impulsion d’horloge qui suit le trigger.

Hold externe

Si vous souhaitez figer la trame vous devez placer la broche Hold à l’état haut pendant le temps de la pause. Le fait de relâcher la patte Hold relancera le pattern de façon synchrone si vous êtes en horloge interne. Par exemple, si l’entrée Hold passe à l’état haut à la moitié d’un cycle d’horloge, lorsque la broche Hold sera relachée, le prochain bit sera dirigé vers les sorties un demi cycle d’horloge plus tard.

Lorsque la broche hold passe à l’état haut, la clock interne est suspendue. Lorsque la broche hold est relachée, la clock repart relative ment au point du cycle lors duquel elle a été suspendue.

Fonctionalités additionnelles

Chargement et sauvegarde des trames.

Les fichiers contenant des trames peuvent être modifiés ou sauvegardés en cliquant droit sur la grille de saisie des trames et en lançant la commande appropriée du menu contextuel.

Les scripts de patterns sont du texte sans formatage particulier – des listes d’octets séparés par une virgule où chaque octet représente une colonne de la grille. Chaque ligne qui débute par un point -virgule sera considérée comme une ligne commentaire. Par défaut le format de l’octet est un nombre hexadécimal, bien qu’il soit possible d’entrer des valeurs en décimal, binaire ou hexadécimal.

Définir des valeurs précises pour les contrôles.

Vous pouvez définir des valeurs précises de la fréquenc e de trigger en double cliquant sur le contrôle rotatif approprié.

Un champ apparaît pour vous permettre de saisir la valeur souhaitée. Par défaut l’unité de la valeur est une fréquence mais vous pouvez choisir de saisir les informations en secondes ou en fraction de seconde en utilisant les suffixes sec, ms,... De plus, si vous souhaitez que le trigger soit un multiple exact du bit d’horloge, vous pouvez ajouter le suffixe ‘bits’ après (tel que 5bits).

Pour confirmer la valeur saisie pressez la touche Entrer. Pour l’annuler, pressez la touche Echape ou cliquez n’importe où dans la fenêtre du générateur de trame.

Ces valeurs peuvent également être indiquées avant la simulation par l'intermédiaire des propriétés lors de l’édition de ce générateur.

Définir d es valeurs spécifiques de la grille de trame.

Vous pouvez attribuer une valeur spécifique à toute colonne de la grille en cliquant sur le texte qui indique sa valeur actuelle. Un champ apparaît pour vous permettre de saisir la valeur souhaitée. Vous pouvez définir des valeurs en décimal (comme 135), en hexadécimal (comme 0xA7) ou en binaire (comme 0b10110101).

Pour confirmer la valeur saisie pressez la touche Entrer. Pour l’annuler, pressez la touche Echape ou cliquez n’importe où dans la fenêtre du générateur de trame.

Pour plus de rapidité vous pouvez remplir une colonne en plaçant le curseur de la souris sur la colonne et en lançant le raccourci clavier CTRL+1. Pour effacer le raccourci clavier est CTRL+SHIFT+1.

Indiquer manuellement la période de la trame.

Vous pouvez définir une période manuellement en cliquant gauche juste au-dessus de la grille à la colonne sur laquelle la trame doit se terminer. Pour dévalider la période, cliquez droit au même endroit.

Progression en pas à pas

Le bouton Step sert à avancer la simulation d’une durée spécifiée en interne ou équivalente à une horloge externe. La simulation durera jusqu’à la fin du cycle d’horloge et sera suspendue à nouveau.

Permutation du mode d’affichage de la grille

Pour afficher les valeurs de la grille en hexadécimal, utilisez le raccourci clavier CTRL+X (heXadécimal). Pour afficher les valeurs de la grille en décimal, utilisez le raccourci clavier CTRL+D (décimal). Vous pouvez également le faire depuis le menu contextuel (clic droit sur la grille).

Choix des sorties.

Editez le générateur de trame placé sur le schéma. Choisissez alors quelles sorties vous souhaitez utiliser pour les trames (bus et pins, pins uniquement, bus uniquement).

Affichage de l’info-bulle.

Vous pouvez autoriser l’affichage de l’info-bulle, permettant de visualiser les informations de la ligne et de la colonne courante, via le menu contextuel ou le raccourci clavier CTRL+Q.

Veuillez noter que l’info-bulle est dévalidée durant les commandes bloc présentées cidessous.

Edition en bloc.

Vous pouvez utiliser les commandes Block Set et Block Clear pour vous aider à configurer rapidement votre trame. Ils sont accessibles via le menu contextuel ou le raccourci clavier (CTRL+S pour Block Set et CTRL+C pour Block Clear). Notez que ces commandes sont désactivées lorsque vous êtes en mode info-bulle.


Timer Counter

MODELE COMPTEUR/TIMER

Généralités

Le Compteur/Timer VSM est un instrument numérique universel qui peut être utilisé pour mesurer des intervalles de temps, la fréquence d’un signal et compt er des impulsions.

Il possède les caractéristiques suivantes:

  • Mode Timer (secondes), résolution 1μs.

  • Mode Timer (heures-minutes-secondes), résolution 1ms.

  • Mode fréquencemètre, résolution 1Hz .

  • Mode compteur – valeur maximum 99 999 999.

L’information de tem ps, de fréquence ou de comptage est affichée à la fois sur le composant du schéma et, optionnellement, sur la fenêtre du compteur/timer représentée ci-dessus. Pour visualiser la fenêtre de ce composant virtuel, veuillez cocher l’option VSM Counter Timer du menu 'Mise au point' lorsque la simulation est lancée.

Utilisation du mode Timer

Pour mesurer un intervalle de temps:

  1. Selectionnez l'icône 'Multimètre', puis placez l’objet COUNTER TIMER sur le schéma.

  2. Si nécessaire, reliez la broche CE (clock enable) à un signal représentatif de l’avancement du temps. Si vous n'avez pas besoin d'une horloge laissez cette entrée “en l’air”.

  3. Si nécessaire, reliez la broche RST (reset) à un signal qui permettra de réinitialiser l’état du timer à zéro. Si vous n'avez pas besoin d'une horloge laissez cette entrée “en l’air”.

  4. Pointez sur le compteur timer et éditez-le grâce à la combinaison clavier CTRL+E.

  5. Sélectionnez le mode timer requis (seconde ou heure-minute-seconde) et les polarités logiques de signaux CE et RST.

  6. Lancez la simulation de la manière habituelle.

La broche RST est active sur front et non sur niveau. Si vous devez maintenir le compteur à zéro, vous pouvez utiliser une combinaison des broches CE et RST.

La fenêtre compteur/timer contient un bouton de remise à zéro manuelle pouvant être actionné à tout moment lors de la simulation. Cette fonctionnalité peut être très utile dans les systèmes embarqués lorsque vous utilisez le compteur/timer pour mesurer le temps d’exécution de certaines sections de programme.

Utilisation du mode Fréquence

Pour mesurer la fréquence d’un signal numérique:

  1. Selectionnez l'icône 'Multimètre', puis placez l’objet COUNTER TIMER sur le schéma. Reliez -le à votre circuit de la même manière qu’un composant.

  2. Connectez la broche CLK (clock) au signal à mesurer. Les broches CE et RST ne sont pas utilisées en mode fréquence.
  3. Pointez sur le compteur timer et éditez-le grâce à la combinaison clavier CTRL+E puis sélectionnez le mode 'Fréquence'.

  4. Lancez la simulation de la manière habituelle.

Le fréquencemètre fonctionne en comptant le nombre de fronts montants qui se produisent chaque seconde. Par conséquence, pour que la valeur retournée soit correcte, il faut que le signal analysé soit simulé pendant au moins une seconde. Egalement, si la simulation ne s’effectue pas en temps réel (lié à une charge trop importante du processeur), la durée de simulation minimale pour afficher une information s’en trouvera rallongée.

Le compteur/timer est un composant entièrement numérique. Pour mesurer la fréquence d’un signal analogique faible, vous devez placer une primitive ADC avec des seuils logiques appropriés devant la pin CLK du compteur/timer. Sachant que la simulation analogique est 1000 fois plus lente que la simulation numérique, il est préférable de ne pas utiliser ce composant virtuel pour mesurer la fréquence d’un circuit oscillant analogique au -dessus de 10kHz. Vous devriez alors utiliser l’oscilloscope virtuel (ou un graphe) pour mesurer la période du signal.

Utilisation du mode Compteur

Pour compter des impulsions numériques:

  1. Selectionnez l'icône 'Multimètre', puis placez l’objet COUNTER TIMER sur le schéma. Reliez -le à votre circuit de la même manière qu’un composant.

  2. Si nécessaire, reliez la broche CE (clock enable) à un signal représentatif de l’avancement du compteur. Si vous n'avez pas besoin d'une horloge laissez cette entrée “en l’air”.

  3. Si nécessaire, reliez la broche RST (reset) à un signal qui permettra de réinitialiser l’état du compteur à zéro. Si vous n'avez pas besoin d'une horloge laissez cette entrée “en l’air”.

  4. Pointez sur le compteur timer et éditez-le grâce à la combinaison clavier CTRL+E.
  5. Sélectionnez le mode Counter et les logiques appropriées des broches CE et RST.

  6. Lancez la simulation de la manière habituelle.

Le compteur s’incrémente sur des transitions front montant de CLK lorsque CE est active.

La broche RST est active sur front et non sur niveau. Si vous devez maintenir le compteur à zéro, vous pouvez utiliser une combinaison des broches CE et RST.

La fenêtre compteur/timer contient un bouton de remise à zéro manuelle pouvant être actionné à tout moment lors de la simulation.


Virtual Terminal

MODELE DE TERMINAL VIRTUEL

Généralités

Ce Terminal vous permet d’utiliser le clavier et l’écran de votre PC pour envoyer et/ou recevoir des données séries RS232 asynchrone vers et depuis un système à microprocesseur. Il peut être utilisé par exemple pour afficher les messages de mises au point de vos programmes.

Le terminal virtuel possède les caractéristiques suivantes :

  • Le terminal virtuel est entièrement bi-directionnel. Les données séries reçues sont affichés en tant que caractères ASCII. Lorsque vous appuyez sur les touches de votre clavier, les données émises sont des caractères ASCII.
  • Interface de donnée série composée de deux fils simples: RXD pour recevoir des données et TXD pour en envoyer.
  • Interface deux fils de ‘poignées de main’: RTS pour “ready-to-send” et CTS pour “clear -to-send”.
  • Vitesse de transfert de 300 à 57 600 baud.
  • 7 ou 8 de bits de données.
  • Parité impaire, paire ou aucune.
  • 0, 1 ou 2 bits de stop.
  • Poignée de main logicielle XON/XOFF en plus de celle matérielle.
  • Polarité normale ou inverse pour les deux signaux RX/TX et RTS/CTS.

Utilisation du Terminal virtuel

Pour attacher un terminal télétype à votre sy stème:

  1. Selectionnez l'icône 'Multimètre' et placez l’objet VIRTUAL TERMINAL sur le schéma.

  2. Reliez les pattes RX et TX aux lignes de transmission et de réception. RX est une entrée et TX une sortie.

  3. Si votre système utilise une poignée de main hardware, reliez les broches RTS et CTS aux lignes appropriées. RTS est une sortie, signalant que le terminal est prêt à recevoir des données, tandis que CTS est une entrée qui doit être à l’état haut (ou non connectée) avant une transmission du terminal.

  4. Éditer le composant terminal virtuel pour sélectionnez la vitesse de transfert adéquate ainsi que la longueur des mots, la parité, le contrôle de flux et la polarisation.

  5. Lancez la simultation de la manoère habituelle. Le terminal affiche alors les données entrantes au fur et à mesure de leur réception. Pour transmettre des caractères au système assurez-vous que le terminal a le focus avant de saisir un texte au clavier devotre PC.

  6. Une fois la simulation lancée, vous avez accès à une multitude de fonctions via le menu contextuel. Pour l’afficher cliquez droit sur la fenêtre du terminal. Ce menu vous permet de mettre en pause l’afficheur et de réaliser des opérations de copier/coller depuis ou vers le presse-papiers.

Le terminal virtuel supporte les codes de contrôle ASCII CR (0Dh), BS (0x08h) et BEL (0x07h). Les autres codes, y comprit LF (0x0A), sont ignorés.

Le terminal virtuel est un modèle entièrement numérique et ne nécessite aucune tension particulière sur ses broches. Il a été conçu de manière à être relié de préférence à un CPU ou une UART plutôt qu’a la sortie d’un MAX232 (pilote RS232) qui intègre des inverseurs logiques.

Les pattes RX et TX sont actives à l’état haut par défaut. Ainsi l’état d’inactivité (idle ) est haut, le bit de start est bas, et le bit de stop est haut. Les bits de données sont considérés à l’état logique haut pour ‘1’ et à l’état bas pour ‘0’. Cette configuration est directement compatible avec les UARTs internes de nombreux microcontrôleurs ainsi que les UARTs externes comme les 6850 et les 8250. Si ce n'est pas le cas (généralement lorsque vous avez relié le terminal à la sortie d’un driver RS232) vous devrez inverser la polarité des signaux RX/TX.

Les broches RTS et CTS sont également actives à l’état haut. Si vous souhaitez connecter le terminal sur des lignes de contrôle inversée (c'est-à-dire RTS/CTS barre), vous devrez configurer la polarité des signaux RTS/CTS sur inverted.

Par défaut, le terminal n’affiche pas l’écho des caractères que vous tapez; il considère que ce sera à votre système de réaliser l’écho. Si vous souhaitez que ce soit le terminal qui réalise cette opération, sélectionnez l’option Echo Typed Characters via le menu contextuel.

Vous pouvez définir un texte qui sera envoyé à votre circuit au démarrage en utilisant la propriété TEXT.

TEXT="Bonjour"

transmettra le texte "Bonjour", caractère par caractère après le démarrage, à moins que CTS soit inactif.

Le modèle MAX232

Proteus VSM intègre un modèle du composant MAX232 (driver RS232), il est ainsi possible de connecter le terminal virtuel à une CPU de la manière suivante:

Il est essentiel de rappeler que le MAX232 intègre des inverseurs logiques et qu’en conséquence la polarité des signaux RX/TX doit être inversée.

Veuillez également noter que le MAX232 est un modèle uniquement numérique – aucune simulation des convertisseurs de tensions internes n’est réalisé. Cela entrainerait des temps d’exécution importants sans intérêt majeur. Cette augmentation des temps de simulation s’applique également si vous reliez des composants analogiques (résistances, condensateurs, oscilloscope, etc.) aux pins TxOut/RxIn.


SPI Debugger

ANALYSEUR DE PROTOCOLE SPI

Généralités

L’analyseur de protocole SPI vous permet de visualiser et d’interagir avec une interface SPI. Le debuggeur affiche les données qui transitent sur le bus SPI et permet également d’en envoyer.

Le debuggeur a trois modes de fonctionnement:

  • Mode esclave: le terminal se comporte comme un périphérique esclave SPI.
  • Mode maître: le terminal se comporte comme un périphérique maître SPI.
  • Mode moniteur: le terminal affiche toutes les informations qui transitent sur le bus SPI.

Le composant du schéma

Le composant du schéma est présenté ci-dessous:

Descriptions des broches

Broche SCK:

La broche SCK est une broche bidirectionnelle reliée à l'horloge du bus SPI. En mode esclave, cette broche est une entrée. En mode maître elle devient une sortie.

Broche DIN:

Les données entrent dans le Debugger SPI par la broche DIN.

Broche DOUT:

Les données sortent du Debugger SPI par la broche DOUT.

Broche SS:

La broche SS permet de sélectionner le mode esclave et doit être active pour que le terminal réponde. Dans le mode maître cette broche est activée lorsque des données sont transmises.

Broche TRIG:

La broche TRIG est une entrée qui permet de placer la prochaine séquence SPI dans la file d’attente de sortie.

La fenêtre du debugger SPI

La fenêtre de l’analyseur de protocole peut être lancée depuis le menu ‘Mise au point’ lorsqu’elle n’apparaît pas automatiquement au lancement de la simulation ou lorsque la simulation est suspendue. Cette fenêtre est découpée en plusieurs zones permettant de surveiller efficacement l’activité du bus SPI, ainsi que de stimuler les bus en mode maître ou esclave.

Visualisation des données en entrée

La zone principale – en haut et à gauche – montre l’activité mémorisée sur le bus. Comme indiqué dans l’exemple ci-dessus, vous pouvez obtenir un niveau de détail au bit près.

Lorsque vous visualisez les données au niveau octet (byte) ou supérieur, le temps de début et de fin de la séquence est mémorisé. Lorsque vous visualisez les données au niveau bit, l’état logique des pins et le bit designator sont mémorisé en plus du temps.

Bien que non représentés dans l’exemple ci-dessus, les flèches sont bidirectionnelles pour indiquer une émission ou une réception de données (réception dans notre cas), et la flèche est remplacée par un point d’interrogation lorsqu’une séquence invalide est détectée. Toutes ces possibilités autorisent un débogage efficace de problèmes potentiels.

Liste des séquences prédéfinies

La liste de séquences prédéfinies en haut et à droite affiche la liste des séquences de données préprogrammées mises dans la file d’attente pour transmission sur le bus. Vous pouvez ajouter des séquences (utiliser le bouton ‘Add’ pour ajouter la nouvelle séquence à la liste existante).

Le fait de double cliquer sur une séquence prédéfinie (ou de mettre en surbrillance la séquence puis de cliquer sur le bouton Queue) pendant une simulation, ajoutera la séquence à la liste des séquences mises dans le tampon de transmission. Notez que l’instant d’émission dépend de l’activité sur le bus, si vous êtes en maître ou esclave, etc et risque donc de ne pas être instantanée.

Liste des séquences tamponnées

La liste des séquences dans le tampon d’émission est présente dans la partie inférieure gauche de la fenêtre et seront transmises par l’analyseur SPI dès que possible.

Champ de description d’une séquence

Ce champ (partie inférieure droite de la fenêtre) permet d’entrer des séquences à placer soit dans la liste des séquences préprogrammées , ou immédiatement dans la liste en sortie qui sera transmise sur la pin DOUT dès que possible. La syntaxe suivante est acceptée

Syntax | Description
'0x' | Référence une valeur hexadécimale (ex : 0xFE)
'$' | Référence une valeur hexadécimale (ex : $FE)
'h' | Référence une valeur hexadécimale (ex : FEh)
'%' | Référence une valeur binaire (ex : %1101)
'b' | Référence une valeur binaire (ex : 1101b)
'd' | Référence une valeur décimale (ex : 47d)

Notez que les valeurs hexadécimales et binaires incluent obligatoirement un préfixe ou un suffixe. Le suffixe pour les nombres décimaux est optionnel. Les chaînes de caractères sont entourées d’apostrophes ou de guillemets.

Utilisez les boutons de contrôle pour indiquer si la séquence doit être ajoutée à la liste prédéfinie ou à la liste tamponnée (Buffered/Queued).

Boutons de contrôle

Les boutons de contrôle sont utilisés pour fournir des stimuli au bus SPI. L’analyseur de protocole fonctionne en mode maître ou esclave ce qui permet de tester totalement votre implémentation SPI.

Bouton 'Ajouter'

Utilisez ce bouton pour ajouter la séquence dans la liste des séquences prédéfinies pour un usage ultérieur.

Bouton 'Supprimer'

Utilisez ce bouton pour supprimer une séquence de la liste des séquences prédéfinies.

Bouton 'Queue'

Utilisez ce bouton pour tamponner les items sélectionnés dans le champ d’entrée ou dans la liste des séquences prédéfinies. Les items tamponnés apparaîtront dans la liste Buffered.

Propriétés du modèle

Le débugger SPI possède plusieurs propriétés qui permettent de le configurer. Toutes les propriétés sont accessibles via la boite de dialogue d’édition du composant (clic droite puis gauche sur le composant du schéma). Voici le détail des propriétés:

Propriété | Description
WORDLENGTH | Indique le nombre de bits de chaque mot transmis. Nombre compris entre 1 et 16 inclus.
BITORDER | Indique l’ordre des bits de chaque mot transmis. Ce peut être le MSB ou le LSB en premier.
SAMPLEEDGE | Indique si l’échantillonnage de la pin DIN se fait lorsque SCK passe de idle à actif ou lorsque les transitions passent de active à idle
IDLESTATE | Indique si SCK est en idle à l’état haut ou à l’état bas.
STOPONEMPTY | Indique si la simulation doit être suspendue lorsque le tampon de sortie est vide.
SEQUENCE_FILE | Fournit un nom de fichier qui contient les séquences prédéfinies. Lorsque cette propriété est vide, les séquences sont sauvegardées dans les propriétés du composant.
MODE | Contrôle la sélection du mode maître ou esclave.
CLOCKFREQ | En mode maître, contrôle la fréquence d’horloge sur SCK.
AUTOLOAD | Indique si les séquences prédéfinies sont immédiatement placées dans le tampon des séquences au lancement de la simulation.
WRAPLENGTH | Indique le nombre de mots autorisés par ligne avant de créer une nouvelle ligne.
TIMEPREC | Nombre de décimales pour l’affichage du temps.
DATAINVERT | Indique si les données sur DOUT et DIN sont inversées.
LOOPBACK | Si validé, tout mot reçu est tamponné en vue d’une transmission.

Utilisation du debugger SPI

Pour recevoir une donnée avec le debugger SPI :

Pour recevoir une donnée sur le bus SPI, il faut connecter les broches SCK et DIN du terminal aux broches appropriées du projet, puis indiquer la lar geur du mot, l’ordre de bits, l’état idle de SCK et les propriétés d’échantillonnage du modèle. La donnée sur le bus SPI sera affichée dans la partie supérieure gauche de la fenêtre, en valeur hexadécimale. Si la donnée reçue est incomplète, par exemple lorsque SS devient inactive avant la réception du mot complet , des astérisques sont affichés à la place de la valeur hexadécimale.

Si les bits du mot reçu sur DIN sont flottants du fait d’une contention, alors la valeur hexadécimale sera affichée avec des points d’interrogation.

Pour émettre une donnée avec les debugger SPI:

Emettre une donnée sur le bus SPI nécessite de connecter les broches SCK et DOUT aux broches appropriées du projet, puis indiquer la largeur du mot, l’ordre de bits, l’état idle de SCK et les propriétés d’échantillonnage du modèle.

La transmission des données se fait dans la partie inférieure droite de la fenêtre, juste audessus des boutons. Les entrées peuvent être des mots simples, des virgules ou des espaces qui séparent une suite de mots, ou des chaînes de caractères entourées d’apostrophes ou de guillemets droits. Les mots peuvent être des valeurs décimales, hexadécimales ou binaires.

Les valeurs hexadécimales utilisent les préfixes '0x' ou '$', ou le suffixe 'h'. Les valeurs binaires utilisent le préfixe '%' préfixe ou le suffixe 'b'. Les valeurs décimales ne nécessitent aucun préfixe et peuvent éventuellement utiliser le suffixe 'd'.

Lorsque vous avez entré votre séquence à transmettre, vous pouvez la placer soit dans le tampon des données à envoyer – dans ce cas cliquez sur le bouton Queue -, soit dans la liste des séquences prédéfinies pour une utilisation ultérieure – dans ce cas cliquez sur le bouton 'Ajouter'.

Pour transférer une copie d’une séquence prédéfinie vers le tampon des séquences , assurezvous que le champ d’entrée d’une séquence soit vide, puis sélectionnez la séquence prédéfinie et appuyez sur le bouton 'Queue'.

Pour supprimer une séquence prédéfinie, commencez par la sélectionner puis cliquez sur le bouton 'Supprimer'.


I2C Debugger

ANALYSEUR DE PROTOCOLE I2C

Généralités

L’analyseur de protocole I2C vous permet de visualiser et d’interagir avec le bus I2C. L’analyseur affiche les données qui transitent sur le bus I2C et permet également d’en envoyer, que ce soit en mode maître ou esclave. C’est donc un outil particulièrement intéressant qui permet de développer et de tester vos programmes I2C (sans parler du coût réduit par rapport à une électronique de test à développer).

Le composant du schéma

Le composant qui analyse le protocole I2C est montré ci-dessous.

Description des pins

Broche SCL:

La broche SCL est bidirectionnelle et doit être connectée à la ligne horloge (clock) du bus I2C.

Broche SDA:

La broche SDA est bidirectionnelle et doit être connectée à la ligne données (data) du bus I2C.

Broche TRIG:

La broche TRIG est une entrée qui transfère les séquences sauvegardées dans la pile de sortie.

La fenêtre de l'analyseur de protocole I2C

La fenêtre de l’analyseur de protocole peut être lancée depuis le menu ‘Mise au point’ lorsqu’elle n’apparaît pas automatiquement au lancement de la simulation ou lorsque la simulation est suspendue. Cette fenêtre est découpée en plusieurs zones permettant de surveiller efficacement l’activité du bus I2C, ainsi que de stimuler les bus en mode maître ou esclave.

Notez que lors d’une simulation dans laquelle l’activité du bus I2C est intense, l’utilisation d’un analyseur de protocole sollicitera les intensément ressources du processeur. Dans les phases de debug ou pour contrôler l’activité, il peut être utile de détacher le composant lors de passes de simulation non-bus.

Visualisation des données en entrée

La zone principale – en haut et à gauche – montre l’activité mémorisée sur le bus. Comme indiqué dans l’exemple ci-dessus, vous pouvez obtenir un niveau de détail au bit près. Les caractères spéciaux utilisés pour représenter l’activité sont explicites .

Lorsque vous visualisez les données au niveau octet (byte) ou supérieur, le temps de début et de fin de la séquence est mémorisé. Lorsque vous visualisez les données au niveau bit, l’état logique des broches et le bit designator sont mémorisés en plus du temps.

Bien que non représentés dans l’exemple ci-dessus, les flèches sont bidirectionnelles pour indiquer une émission ou une réception de données (réception dans notre cas), et la flèche est remplacée par un point d’interrogation lorsqu’une séquence invalide est détectée. Toutes ces possibilités autorisent un débogage efficace de problèmes potentiels.

Liste des séquences prédéfinies

La liste de séquences prédéfinies , en haut et à droite, affiche la liste des séquences de données préprogrammées qui peuvent être transmises sur la broche SDA sous contrôle de la broche SCL. Pour ajouter une séquence à la liste, il faut la définir dans le champ d’entrée et la valider par un clic sur le bouton 'Ajouter'.

Le fait de double cliquer sur une séquence prédéfinie (ou de met tre en surbrillance la séquence puis de cliquer sur le bouton Queue) pendant une simulation, ajoutera la séquence à la liste des séquences mises dans le tampon de transmission. Notez que l’instant d’émission dépend de l’activité sur le bus, si vous êtes en maître ou esclave, etc et risque donc de ne pas être instantanée.

Liste des séquences tamponnées

La liste des séquences dans le tampon d’émission est présente dans la partie inférieure gauche de la fenêtre et seront transmises par l’analyseur I2C dès que possible. Pour ajouter une séquence à la liste, il faut la définir dans le champ d’entrée et la valider par un clic sur le bouton Queue.

Champ de description d’une séquence

Ce champ (partie inférieure droite de la fenêtre) permet d’entrer des séquences à placer soit dans la liste des séquences préprogrammées , ou immédiatement dans la liste en sortie qui sera transmise sur la broche SDA dès que possible. La syntaxe suivante est acceptée.

Syntaxe | Description
'0x' | Référence une valeur hexadécimale (ex : 0xFE)
'$' | Référence une valeur hexadécimale (ex : $FE)
'h' | Référence une valeur hexadécimale (ex : FEh)
'%' | Référence une valeur binaire (ex : %1101)
'b' | Référence une valeur binaire (ex : 1101b)
'd' | Référence une valeur décimale (ex : 47d)

Notez que les valeurs hexadécimales et binaires incluent obligatoirement un préfixe ou un suffixe. Le suffixe pour les nombres décimaux est optionnel. Les chaînes de caractères sont entourées d’apostrophes ou de guillemets.

Utilisez les boutons de contrôle pour indiquer si la séquence doit être ajoutée à la liste prédéfinie ou à la liste tamponnée (Buffered/Queued).

Boutons de contrôle

Les boutons de contrôle sont utilisés pour fournir des stimuli au bus I2C. L’analyseur de protocole fonctionne en mode maître ou esclave ce qui permet de tester totalement votre implémentation I2C.

Bouton 'Ajouter'

Utilisez ce bouton pour ajouter la séquence dans la liste des séquences prédéfinies pour un usage ultérieur.

Bouton 'Supprimer'

Utilisez ce bouton pour supprimer une séquence de la liste des séquences prédéfinies.

Bouton 'Queue'

Utilisez ce bouton pour tamponner les items sélectionnés dans le champ d’entrée ou dans la liste des séquences prédéfinies. Les items tamponnés apparaîtront dans la liste Buffered.

Propriétés du modèle

L'analyseur de protocoleI2C possède plusieurs propriétés qui vous permettent de le configurer en fonction de vos besoins. Toutes ces propriétés sont accessibles à partir de la boite de dialogue d'édition des composants (clic droit sur le composant du schéma pour le mettre en surbrillance, puis clic gauche pour l'édition). Les détails de chaque propriété vous sont donnés ci-dessous:

Propriétés | Description
ADDRESS1 | Si vous utilisez le modèle pour simuler un périphérique esclave, cette propriété précise du premier octet de l’adresse. Le bit le moins significatif sert au maître pour indiquer si la transmission est une lecture ou une écriture, et n’intervient pas dans l’adresse.
ADDRESS2 | Si vous utilisez le modèle pour simuler un périphérique esclave, avec une adresse sur 10 bits, cette propriété précise le second octet de l’adresse. Si cette propriété est vide, l’adresse sera sur 7 bits du périphérique.
STOPONEMPTY | Indique si la simulation doit être suspendue lorsque le tampon de sortie est vide.
CLOCKFREQ | En mode maître, contrôle la fréquence d’horloge sur SCL.
SEQUENCE_FILE | Fournit un nom de fichier qui contient les séquences prédéfinies. Lorsque cette propriété est vide, les séquences sont sauvegardées dans les propriétés du composant.
AUTOLOAD | Indique si les séquences prédéfinies sont immédiatement placées dans le tampon des séquences au lancement de la simulation.
TIMEPREC | Nombre de décimales pour l’affichage du temps.
WRAPLENGTH | Indique le nombre de mots autorisés par ligne avant de créer une nouvelle ligne.

Utilisation du debugger I2C

Pour recevoir une donnée avec le debugger SPI:

Pour recevoir une donnée sur le bus SPI, il faut connecter les broches SCL et SDA du terminal aux broches appropriées du projet. Les données sur le bus I2C seront affichées dans la partie supérieure gauche de la fenêtre, en valeurs hexadécimales avec des caractères spéciaux .

Pour émettre une donnée avec les debugger I2C:

Emettre une donnée sur le bus SPI nécessite de connecter les broches SCL et SDA aux broches appropriées du projet.

La transmission des données se fait dans la partie inférieure droite de la fenêtre, juste au-dessus des boutons. Les entrées peuvent être des mots simples, des virgules ou des espaces qui séparent une suite de mots, ou des chaînes de caractères entourées d’apostrophes ou de guillemets droits. Les mots peuvent être des valeurs numériques ou des caractères de contrôle.

Lorsque vous avez entré votre séquence à transmettre, vous pouvez la placer soit dans le tampon des données à envoyer – dans ce cas cliquez sur le bouton Queue -, soit dans la liste des séquences prédéfinies pour une utilisation ultérieure – dans ce cas cliquez sur le bouton 'Ajouter".

Pour transférer une copie d’une séquence prédéfinie vers le tampon des séquences, assurez-vous que le champ d’entrée d’une séquence soit vide, puis sélectionnez la séquence prédéfinie et appuyez sur le bouton Queue.

Pour supprimer une séquence prédéfinie, commencez par la sélectionner puis cliquez sur le bouton 'Supprimer'.

Syntaxe de référence

Le tableau suivant détaille la syntaxe utilisée pour représenter les conditions de l’analyse du protocole sur le bus I2C.

Syntaxe | Description
S | Utilisé pour indiquer une condition ‘start’.
Sr | Utilisé pour indiquer une condition ‘restart’.
P | Utilisé pour indiquer une condition ‘stop’.
N | Utilisé pour indiquer une condition ‘acknoledge’ négative.
A | Utilisé pour indiquer une condition ‘acknowledge’.
L | Utilisé pour indiquer que l’arbitrage a été perdu, avec commutation en mode maître.
* | Utilisé pour indiquer la réception d’une donnée partielle.
? | Utilisé pour indiquer la détection de niveaux logiques invalides.


Voltmeters and Ammeters

VOLTMETRES & AMPEREMETRES

Généralités

Proteus VSM contient plusieurs voltmètres et ampèremètres AC et DC. Ceux-ci opèrent en temps réel et peuvent être connectés au circuit comme tout autre composant. Lorsque la simulation est lancée, ils affichent la tension à leurs bornes ou le courant qui les parcoure sous la forme d’une valeur numérique. La déviation pleine échelle (FSD) des appareils peut être fixée à 100, 100m et 100u avec une résolution de 3 chiffres et un maximum de 2 chiffres pour la partie décimale. Pour régler l’échelle, éditez l’objet et paramétrez la propriété Display Range.

Le modèle des voltmètres intègre une résistance de charge interne de 100M par défaut, qui peut être modifiée par simple édition du composant. Le fait de fournir une valeur vierge dévalide la résistance de charge du modèle. Les voltmètres et les ampèremètres AC affichent les valeurs RMS réelles intégrées sur une constante de temps paramétrable par l’utilisateur.


Introduction

INSTRUMENTS VIRTUELS

Les instruments virtuels suivants sont fournis avec Proteus VSM:

  • Oscilloscope
  • Analyseur logique
  • Generateur du signal
  • Generateur de Pattern
  • Compteur/Timer
  • Terminal virtuel
  • Analyseur de protocole SPI
  • Analyseur de protocole I2C
  • Voltmètres et ampéremètres